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1 Цели и задачи курсового проекта 

Курсовой проект ориентирован на практическое закрепление знаний по 

применению персонального компьютера (ПК) с систем автоматизированного 

проектирования в профессиональной деятельности инженера. 

Курсовой проект должен подготовить студентов к последующим этапам 

учебной деятельности – умению решать свои инженерные задачи с помощью 

ПК, применять полученные знания во всех изучаемых дисциплинах и в 

будущем – в выпускной квалификационной работе. 

Важнейшими целями курсового проекта являются закрепление, 

углубление и обобщение студентами знаний, полученных во время обучения, и 

выработка у них умения самостоятельно применять эти знания для творческого 

решения конкретных практических задач, связанных с различными аспектами 

использования компьютерной техники при проектировании радиоэлектронных 

средств (РЭС) и аппаратуры связи. 

Особенностью выполнения курсового проекта является реализация 

поставленных задач на персональном компьютере в одной или нескольких 

интегрированных средах (AWR Design Environment, LabVIEW, Multisim и т.д.) 

Под руководством преподавателя студент должен самостоятельно 

разобраться с поставленными задачами, отладить их на персональном 

компьютере и продемонстрировать преподавателю выполненный результат в 

соответствии с вариантом задания. Работа завершается защитой полученных 

результатов.  

В задачи курсового проектирования ставится овладение основами 

современных системных методов проектирования (расчета) функциональных 

узлов и электрорадиоэлементов, оптимальных по заданным требованиям, в том 

числе и с применением ПЭВМ. Проектирование включает в себя: анализ 

технического задания, выбор оптимального варианта конструкции устройства, 

электрический и конструктивный расчеты, уточнение электромагнитных и 

конструктивных параметров. 
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2 Тематика и содержание курсового проекта 

Тематика курсового проекта посвящена проектированию топологии 

полосового фильтра СВЧ-диапазона. Фильтры применяются во многих 

радиоэлектронных устройствах. Чтобы создать высококачественную 

беспроводную систему связи, требуются микроволновые фильтры с 

определенными частотными характеристиками. 

В настоящее время происходит быстрое развитие моделирования 

миниатюрных фильтров на микрополосковых линиях, соответствующие 

нужным характеристикам. 

Для разработки фильтров необходимо обеспечить требуемые частотные 

характеристики устройства при минимально возможных габаритах. Также 

важна сложность изготовления и последующая настройка. Однако вместе с 

компактностью и технологичностью такая реализация имеет серьезные 

недостатки в виде невысокой собственной добротности (обычно не более 200). 

Это приводит к заметным потерям в полосе пропускания, особенно в 

узкополосных фильтрах, и к увеличению неравномерности: на краях полосы 

пропускания больше, чем в центре. 

При выполнении курсового проекта студенту предлагается выполнить 

расчет геометрических размеров резонаторов полосового фильтра по своему 

варианту задания, выполнить проектирование топологии фильтра и провести 

электродинамическое моделирование. Особенностью курсового проекта 

является применение любой ранее изученной САПР: (AWR Design Environment, 

LabVIEW, Multisim и т.д.). 

Задания, выдаваемые студенту на выполнение курсового проекта, 

отвечают следующим требованиям: 

- соответствуют уровню подготовки студентов и ограничению по 

времени, отведенному на его выполнение; 

- содержат задачи по проектированию узлов, используемых инженером- 

радиотехником; 



5 

- предусматривают необходимость ознакомления с дополнительной 

литературой; 

- допускают выбор студентом темы по иной тематике, но связанной с 

проблемами профессиональной деятельности инженера-радиотехника, 

актуальной и применимой в его практической деятельности. Выбранная таким 

образом тема должна быть согласована с руководителем. 
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3 Требования к выполнению курсового проекта 

При выполнении курсового проекта студенту необходимо выполнить 

следующее: 

1. Студент должен ознакомиться с рекомендуемой учебной литературой и 

внимательно изучить методические указания по выполнению курсовой работы. 

2. Изучить вариант задания. Выбрать структуру фильтра и провести 

расчеты. Выполнить краткий обзор типов фильтров и особенностей их 

реализации и применения 

3. Разобраться с методикой проектирования топологии фильтра.  

4. Реализовать фильтр в САПР AWR DE по своему варианту задания, 

выполнив все требования технического задания. 

5. Заключительным этапом оформления работы являются оформление 

отчета в соответствии со стандартом ОС ТУСУР 01-2013 и его защита. 
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4 Организация и руководство курсовым проектом 

1. Руководитель до начала курсового проектирования подготавливает 

варианты заданий. 

2. Во время первого занятия руководитель доводит до сведения студентов 

номер варианта задания и уточняет конкретное задание для каждого студента. 

Также объявляется возможность выбора тематики студентом лично. В этом 

случае ко второму занятию студент должен проработать техническое задание и 

согласовать его с руководителем. 

3. Ко второму занятию студенты должны начать работу по выполнению 

курсового проекта и активно консультироваться с руководителем. 

4. Контроль за ходом выполнения курсового проекта осуществляется 

руководителем. 

5. Руководитель, в соответствии с установленным графиком, 

осуществляет консультации, на которых студент может уточнить содержание 

теоретической и/или практической частей курсового проекта. 

6. Защита курсового проекта производится на последней неделе семестра 

(на зачетной неделе). Защита позволяет выявить уровень знаний студента, 

степень его самостоятельности в выполнении курсового проекта. Результаты 

защиты оцениваются по пятибалльной системе. 

7. К защите курсового проекта студент допускается при наличии 

печатной, скрепленной и подписанной пояснительной записки (ПЗ). 

8. Завершенная ПЗ сдается руководителю в установленные учебным 

графиком сроки. Руководитель оценивает содержание работы, степень 

самостоятельности ее выполнения, уровень грамотности и определяет, 

допускать ли студента к защите курсового проекта. 

9. Если студент не допущен к защите, то курсового проекта должен быть 

доработан согласно замечаниям руководителя. 
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5 Структура пояснительной записки 

1. Титульный лист, на котором указывается название 

университета, название кафедры, название дисциплины, вид работы, 

тема работы, руководитель, исполнитель, дата (см. Приложение 1). 

2. Реферат, оформленный в соответствии с требованиями ОС 

ТУСУР 01-2013. 

3. Содержание. В содержании указывается наименование 

разделов ПЗ и номера страниц, с которых начинается 

соответствующий раздел. Заголовки оглавления должны точно 

повторять заголовки в тексте. 

4. Введение должно содержать общие сведения о теоретической 

и практической части курсового проекта: 

- краткое обоснование актуальности темы; 

- перечень вопросов, которые раскрывают тему; наименование 

задачи, которая будет решена с использованием пакета (пакетов) 

прикладных программ на ПК н описана в практической части 

курсового проекта. 

5. Задание на курсовой проект. Приводится текст варианта 

задания (см. Приложение 2). 

6. Теоретическая часть имеет целью углубить знания по методам 

расчета электрических цепей постоянного тока и показать умение 

студента работать с литературой и текстовыми редакторами на ПК. 

План изложения теоретической части должен быть продуман и 

составлен студентом после проработки литературных источников и 

согласования с руководителем.  
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7. Практическая реализация решения в программном комплексе, 

показывающая правильность проведенных расчетов. Приводятся 

рисунки по реализации по каждому этапа проектирования. 

8. Заключение. В этой части работы излагаются итоги 

компьютерного проектирования и достигнутые результаты. 

Приводится обзор перспектив изучаемой проблемы, рекомендации по 

практическому применению результатов работы, а также 

предложения по внесению изменений в курсовой проект для 

достижения более корректных результатов. 

9. Список использованных источников. Приводится литература, 

которая использовалась при подготовке и выполнении курсового 

проекта.  
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Приложение 1 (обязательное ) Пример оформления титульного листа 

Пример оформления титульного листа 

Министерство образования и науки Российской Федерации 

 

Федеральное государственное бюджетное образовательное 

учреждение высшего профессионального образования 

 

ТОМСКИЙ ГОСУДАРСТВЕННЫЙ УНИВЕРСИТЕТ 

СИСТЕМ УПРАВЛЕНИЯ И РАДИОЭЛЕКТРОНИКИ (ТУСУР) 

 

Кафедра радиоэлектроники и систем связи (РСС) 

 

 

ПРОЕКТИРОВАНИЕ ФИЛЬТРА НА СВЯЗАННЫХ ЛИНИЯХ 

Пояснительная записка к курсовому проекту 

по дисциплине «Название дисциплины» 

 

 

Студент гр. 147-2 

____________ И.О. Фамилия 

«__»_______2018 г. 

 

Руководитель 

Доцент кафедры РСС 

канд. техн. наук 

____________ И.О. Фамилия 

«__»_______2018 г. 

 

Томск 2018  
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Приложение 2 (обязательное ) Пример оформ лени я задани я на курсово й прое кт 

Пример оформления задания на курсовой проект 

УТВЕРЖДАЮ 

Зав. кафедрой РСС 

___________ Фатеев А.В. 

«____»_____________2018 г 

З А Д А Н И Е   №     2 

на курсовое проектирование по дисциплине 

«Системы компьютерного проектирования РЭС» 

Тема проекта: Проектирование фильтра на связанных линиях. 

Цель: Разработать топологию фильтра, удовлетворяющего техническим 

требованиям и провести электромагнитный анализ его работы. 

1. Технические требования: 
1.1. Центральная частота 5 ГГц 

1.2. Полоса пропускания 4,8 – 5,2 ГГц; 

1.3. Полоса заграждения: f1гр = 4,5 ГГц  

f2гр = 5,5 ГГц; 

1.4. Затухание на границах полосы заграждения 50 дБ; 

1.5. Затухание сигнала в полосе пропускания не 
более: 

4 дБ; 

1.6. Волновые сопротивления подводящих линий 50 Ом; 

2. Исходные данные к проекту: 

2.1. В качестве подложки должен быть использован диэлектрический материал 

с диэлектрической проницаемостью не более 10, толщиной до 3мм. 

2.2. Проектирование топологии фильтра выполнить в среде AWR Design 

Environment 

3. Перечень вопросов, подлежащих разработке:  

3.1.Обзор систем автоматизированного проектирования РЭС. 

3.2. Виды фильтров на основе сосредоточенных элементов и на элементах 

с распределенными параметрами. 
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3.3. Выбор и обоснование структуры фильтра. 

3.4. Расчет параметров фильтра. 

3.5. Проектирование топологии фильтра в среде AWR Design Environment 

3.6. Анализ электромагнитной структуры фильтра с помощью модуля 

EMSight. 

3.7. Заключение. 

Пояснительную записку выполнить в среде Microsoft Word и оформить в 

соответствии с требованиями ОС ТУСУР-2013 и ГОСТ 7.32–20014.  

4. Рекомендуемая литература: 

4. 1  Фуско В. СВЧ цепи. Анализ и автоматизированное проектирование. 

Пер. с англ. – М.: Радио и связь, 1990. 288 c 

4.2 Ковалев И.С. Конструирование и расчет полосковых устройств. – М.: 

Советское радио, 1974. 294 c. 

4.3.Hong J.Sh., Lancaster M.J. Microstrip Filters for RF/Microwave 

Applications. John Wiley & Sons, 2001. 

 
 
 
 
 
 
 
 
Срок сдачи готового проекта С 20 по 30 декабря  2018 г. 

  

Задание принял к исполнению:  

Студент гр.147-1 _____________И.О. Фамилия 

 «____» __________ 2018 г  

 

Руководитель: 

Доцент кафедры РСС,  

канд. техн. наук  

 

____________ И.О. Фамилия 

«____»___________ 2018 г  
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Приложение 3 (обязательное ) Варианты  задани я на курсово й прое кт 

Варианты задания на курсовой проект 

Параметры фильтров 

№ 
вар. 

Центральная 
частота 
f0, ГГц  

Полоса 
пропускания 
∆f, ГГц 

Полоса 
заграждения 

f1гр, ГГц 

Полоса 
заграждения 

f2гр, ГГц 

Коэффициент 
подавления 

(заграждения) 
Кзагр, дБ 

Коэффициент 

передачи 

Кп, дБ 

1 4 3,8-4,2 3,5 4,5 -44 -5 
2 5 4,8-5,2 4,5 5,5 -50 -4 
3 4,5 4,3-4,7 4 5 -50 -5 
4 3 2,7-3,3 2,5 3,5 -45 -5 
5 3,5 3,3-3,7 2,7 4,3 -40 -4 
6 4,2 3,8-4,6 3,5 4,9 -44 -5 
7 6 5,8-5,2 5,5 6,5 -40 -4 
8 5,5 5,3-5,7 5 6 -55 -3 
9 7 6,7-3,3 2,5 3,5 -45 -5 
10 6,5 6,3-3,7 6,7 6,3 -40 -3 

 
Подложки микрополосковых линий 

 
№ 
вар. 

Диэлектрик подложки H, мм ε 
tgδ, 
х10-3 

Частота, 
ГГц 

1 Арилокс с наполнителем ФЛАН-10 2 10 1,5 2 
2 Поликор 2 9,6 0,1 3 
3 Фторопласт ФФ-4 2 2,1 0,3 4 
4 Арилокс с наполнителем ФЛАН-3,8 2 3,8 1,2 5 
5 Фторопласт армированный ФАФ-4 1 2,6 1 6 
6 Арилокс с наполнителем ФЛАН-5 1 5 1,2 7 
7 Стеклотекстолит 1 4,5 25 8 
8 Полистирол с наполнителем СТ-3 1 3 9 9 
9 Плавленный кварц 1 3,8 0,1 10 
10 Арилокс с наполнителем ФЛАН-10 1,5 10 1,5 2 
11 Поликор 1,5 9,6 0,1 3 
12 Фторопласт ФФ-4 1,5 2,1 0,3 4 
13 Арилокс с наполнителем ФЛАН-3,8 1,5 3,8 1,2 5 
14 Фторопласт армированный ФАФ-4 0,5 2,6 1 6 
15 Арилокс с наполнителем ФЛАН-5 0,5 5 1,2 7 
16 Стеклотекстолит 0,5 4,5 25 8 
17 Полистирол с наполнителем СТ-3 0,5 3 9 9 
18 Плавленный кварц 0,5 3,8 0,1 10 
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Приложение 4 (справочное) Пр имер прое ктир ован ия фильтра в AWR Des ign Environ ment 

Пример проектирования фильтра в AWR Design Environment 

1 Расчет полоскового фильтра 

Требуется разработать полосовой фильтр сверхвысоких частот. 

Наилучшим образом для данной частоты подойдет микрополосковый фильтр, 

показанный на рисунке 1. В отличие от фильтра на сосредоточенных элементах, 

данный фильтр более стабилен и в нем не сказываются паразитные параметры 

сосредоточенных элементов. 

 

1 – входной порт, 2 – выходной порт,  

3 – микрополосковые резонаторы, 4 – заземление 

Рисунок 1.1 – Структура полосового фильтра 

Число микрополосковых резонаторов определите по формуле: 

, 

(1) 

где   L3 – затухание в полосе заграждения,  

Ln – затухание в полосе пропускания,  

П3 – полоса заграждения,  

Пп – полоса пропускания. 

Подставляя значения в формулу 1, определите количество необходимых 

резонаторов. 

По формуле 2 найдите длину полоскового резонатора. 
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(2) 

где    λ0  – длина волны, 

εг – диэлектрическая проницаемость микрополоска,  

с  – скорость света, 

 f0 – центральная частота. 

Ширину проводника найдите по формуле 3.  

Расстояние между резонаторами равно ширине резонатора. 

 
(3) 

Дальнейшее проектирование фильтра будем вести в программе AWR 

Design Environment. 

Для начала проектирования необходимо открыть программу: Пуск>AWR 

Design Environment. После чего откроется программа. 
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2 Проектирование топологии фильтра 

2.1 Создание ЕМ структуры 

Для создания нового проекта выполните следующие операции: 

1. Выберите Project>Add ЕМ Structure>New ЕМ Structure 

2. Напечатайте «Interdigital Filter» в колонке имени (Enter a name for the 

EM Structure), в окне «Available Simulators» выберете «AWR EMSight 

Simulator»  и нажмите Create. В рабочем окне MWO появляется окно ЕМ 

структуры (рисунок 2.1). 

 

Рисунок 2.1 – Окно EM струкруктуры 

2.2 Задание корпуса 

Корпус задает материал для всех слоев в ЕМ структуре, устанавливает 

граничные условия и определяет общий размер структуры и минимальные 

единицы сетки разбиения которые будут использоваться для спецификации 

материала проводников в структуре. 

Чтобы задать корпус: 

1. Слева, в окне «Project» найдите вкладку «EM Structures», откройте, 

находящуюся под ней «Interdigital Filter» и нажмите два раза на «Enclosure» в 

дереве проекта. Появляется диалог информации о подложке (Рисунок 2.2). 

2. В Value (размеры корпуса), впечатайте «12» в X_Dim (размер по оси 

X), напечатайте «0.1» в Grid_X (количество разбиений по оси X), напечатайте 

«12» в Y-Dim, и «0.1» в Grid_Y. (Рисунок 2.2) 
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Диэлектрические слои устанавливаются в закладке Dielectric Layers. 

Корпус содержит минимум два диэлектрических слоя. Самый верхний 

диэлектрический слой – Layer 1. Часто верхний слой задается как воздушный 

слой, хотя это необязательно. К параметрам диэлектрических слоев относятся 

его толщина (Thickness), относительная диэлектрическая проницаемость (εr), 

тангенс диэлектрических потерь (Loss Tangent). 

 

Рисунок 2.2 – Задание размеров корпуса сетки деления по координатам 

Для определения диэлектрических слоев: 

1. Откройте закладку Material Defs (Рисунок 2.3). 

2. В первом окне (Dielectric Definitions) посмотрите, присутствует ли у вас 

слой. Выставите значение в колонке Er равное «9.8», в колонке TanD «0.001». 

Если слоя нет, то правее этого окна (Dielectric Definitions) нажмите «Add» 

(добавить). Появится новое диалоговое окно (Рисунок 2.4). Напечатайте в 

колонке Name «FLAN», в колонке Er «9.8», в колонке TanD «0.001», в Preset 

оставьте значение по умолчанию. 
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3. В следующем окне (Conductor Definitions) посмотрите, присутствует 

ли у вас слой. Значение Er в нем должно равняться 1, значение Sigma должно 

быть приближено к значению меди – 5.96e+007, если эти значения не верны – 

исправьте. Если слоя нет, то добавьте его, нажав Add правее окна Conductor 

Definitions, в появившемся диалоговом окне  (Рисунок 2.5) найдите третью 

вкладку Presets и выберете в ней Copper (Медь) и нажмите OK. 

4. Затем перейдите в следующую вкладку сверху (Dielectric Layers). В 

этом разделе найдите столбец Layer. У вас должно быть 2 слоя. В строке, 

соответствующей воздуху (Air), в колонке Thickness напечатайте 5, оставьте 

значения по умолчанию в других колонках. Во втором слое напечатайте 

«0.635» в колонке Thickness, и «4» в колонке Draw Scale. 

 

Рисунок 2.3 – Задание параметров материалов 

5. Нажмите кнопку «OK».  
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Рисунок 2.4 – Добавление диэлектрика 

 

Рисунок 2.5 – Добавление проводника 

2.3 Добавление проводников к топологии. 

Вы можете использовать симулятор ЕМSight (AXIEM) для рисования 

физической структуры. Также можно импортировать структуру 

непосредственно из топологического редактора AWR или импортировать 

формы из файлов AutoCAD, DXF, GDSII или Sonnet GEO. Microwave Office 

поддерживает абсолютные координаты и относительные. Абсолютные коорди-

наты относятся ко всему корпусу (подложке) электромагнитной структуры, а 

относительные только к отдельному элементу структуры, например, к 

прямоугольному проводнику. Абсолютная координата x=0 соответствует 

левому краю корпуса электромагнитной структуры, а координата y=0 – 

нижнему краю корпуса. Относительная координата x=0 соответствует левому 
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краю элемента, например, прямоугольного проводника, а y=0 – нижнему краю 

элемента 

1. Щёлкните мышкой по панели Layout в нижней части левого окна, 

чтобы открыть в этом окне менеджер топологии и отметьте «Conductor» 

(Рисунок 2.6). В поле EM Layer введите «2», щёлкнув по кнопке в правом 

конце этого поля. В поле Material выберете «1oz Cu», щёлкнув по кнопке в 

правом конце этого поля. Выберите в меню сверху Draw>Rectangle 

(Чертить>Прямоугольник) или щёлкните левой кнопкой мышки по значку 

Rectangle на панели инструментов. 

 

Рисунок 2.6 – Окно менеджера топологии 

2. Поместите курсор в окно электромагнитной структуры и нажмите 

клавишу Tab на клавиатуре. Откроется диалоговое окно Enter Coordinates 

(Ввод координат), показанное на рисунке 3.7. 

 

Рисунок 2.7 – Начало рисования топологии с помощью ввода координат 

3.  Напечатайте «0» в качестве величин х и «2.2» как величины у, и 

кликните ОК. 
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4.  Нажмите клавишу Tab снова, чтобы увидеть диалог Enter Coordinates. 

Отметьте Re и напечатайте «2.2» как величину dx, и «0.6» как величину dy, и 

затем кликните ОК. Прямоугольный проводник будет иметь вид как на 

Рисунок 2.8. 

 

Рисунок 2.8 – Нарисованная форма проводника фильтра 

Чтобы нарисовать второй прямоугольный проводник: 

5.  Выберите Draw>Rectangle снова. 

6.  Сдвиньте курсор в окно фильтра и нажмите клавишу Tab. Появится 

окно диалога ввода координат Enter Coordinates. Впечатайте «4» как величина х 

и «2» как величину у, и затем кликните ОК. 

7.  Нажмите клавишу Tab снова, чтобы вывести диалог Enter Coordinates. 

Напечатайте рассчитанное значение «w» как величину dx, и «l» как величину 

dy, и затем кликните ОК. Прямоугольный проводник будет иметь вид как на 

рисунке 3.9. 

 

Рисунок 2.9 – Две нарисованные формы проводников фильтра 
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Чтобы сдвинуть второй прямоугольник к первому проводнику: 

8.  Дважды кликните на втором прямоугольнике. Появятся квадратики по 

углам прямоугольника. 

9.  Передвигайте выбранный проводник, пока курсор имеет вид 

пересечения. Значения dx и dy будут показаны в окне. 

Совет. Используйте кнопку Ruler на инструментальной линейке для 

измерения размеров проводника, и размеров структуры ЕМ-топологии 

10. Удерживая кнопку мыши, перетащите курсор до тех пор, пока dx и dy 

не будут соответствовать dx:-2 и dy:-l. При отпускании кнопки мыши 

прямоугольник примет нужное положение. 

2.4 Добавление перемычек VIA 

Перемычки Via это межсоединения между слоями подложки 

(заземления). Вы можете добавить перемычку к земляной плате с одной 

стороны большого проводника к низу металлического корпуса. 

1.  Выберите Draw>Rectangle. 

2.  Сдвиньте курсор в окно фильтра и нажмите клавишу Tab. Появится 

окно диалога ввода координат Enter Coordinates. Впечатайте «2.4» как величина 

х и «1.2» как величину у, и затем кликните ОК. 

3. Нажмите клавишу Tab снова, чтобы увидеть диалог Enter Coordinates. 

Напечатайте «0.4» как величину dx, и «0.8» как величину dy, и затем кликните 

ОК. 

4. Чтобы получить перемычку, сначала выделите ее левой кнопкой мыши, 

а затем нажмите правую. В открывшемся меню кликните на Shape Properties. 

5. Во вкладке Layout выберете Via. Нажмите OK. 

6. Выберите Edit>Сору, затем выберите Edit>Paste. 

7. Сдвиньте мышь в окно ЕМ-структуры. Появится вторая перемычка. 

8. Нажмите правой кнопкой мыши для вращения одной перемычки. 

9. Поставьте перемычки соответственно рисунку 3.12. 

10.  Удостоверьтесь, что копия тоже является перемычкой, в противном 

случае проделайте тоже, что и в пункте 4. 
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Рисунок 2.10 – Установка сечения перемычки Via 

 

Рисунок 2.11 – Диалоговое окно Properties 

2.5 Просмотр трехмерного изображения 

ЕМ симулятор выводит двухмерный и трехмерный виды. Чтобы создать 

3D вид: 

1. Выберите View>3D EM Layout. Появится окно, содержащее 

трехмерный вид конструкции. 
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2. Выберите Window>Tile Vertical. (Рисунок 2.12). 

Заметим, что чтобы изменить вид 3D структуры, кликните правой кнопкой 

мыши в 3D окне. Используйте команды View Area, Zoom Out, View All, для 

ориентировки. 

3. Чтобы вращать 3D структуру, кликните на ней и, удерживая кнопку 

мыши, вращайте. 

4. Если 3D структура не объемна, то зайдите снова в 

Enclosure>Dielectric Layers и удалите 3й слой. Убедитесь, что во втором слое 

во вкладке Thickness стоит значение 0,635. Если нет – исправьте. Нажмите OK. 

 

 

Рисунок 2.12 – Техмерный и двумервый вид части фильтра 

 

2.6 Добавление портов и линий разгерметизации 

ЕМ симулятор может определить электрические порты на краю 

определенного корпуса (краевые порты) и как пробники перемычек, 

проходящие снизу или от поверхности дна (порты via). Для задания краевого 

порта: 

1. Кликните меньший проводник в структуре ЕМ. Заметим, что 

проводник должен быть расположен точно по срезу левого края (Х:0; Y:2.2), 

перед тем, как вы добавите краевой порт к нему. 

Совет: выберите View>Zoom In один или два раза для лучшего 

просмотра вида. 
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2. Выберите Draw>Add Edge Port. 

3. Разместите курсор с левого края маленького проводника пока не 

появится квадратик, и нажмите левую кнопку мыши, для размещения порта. 

Маленький бокс с номером 1 (показывающий номер порта) появится с левого 

края проводника (Рисунок 2.13). 

Для вычитания (разгерметизации) величин электрической длины из 

результата моделирования, референсные плоскости для порта должны быть 

сдвинуты от края корпуса. 

Для разгерметизации 1 мм электрической длины порта 1: 

4. Нажмите правой кнопкой мыши в окне ЕМ структуры, и выберите 

View Area. 

5. Кликните и удерживайте кнопку мыши, чтобы увидеть увеличенный 

курсор, затем протяните курсор вокруг порта 1 и маленького проводника. 

6. Нажмите на порту 1. Четыре квадратика показывает их углы. 

7. Сдвиньте мышь вокруг края порта пока курсор не покажет двойную 

стрелку. 

8. Кликните и удерживайте клавишу мыши и увидеть dx и dy. 

9. Удерживайте кнопку мыши, протащите курсор вправо пока dx не 

покажет 1. Отпустите кнопку мыши чтобы увидеть линию разгерметизации 

(Рисунок 2.14). 
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Рисунок 2.13 – Установка порта к левой грани микрополоскового фильтра 

 

Рисунок 2.14 – Смещение опорной плоскости разгерметизации порта 

2.7 Задание частот моделирования 

Для задания частоты моделирования: 

1. В дереве проекта кликните правой кнопкой на Interdigital Filter под 

ЕМ Structure и выберите Options. Появляется диалог Options. 

2. Выберите закладку Frequencies. 
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3. Деселектируйте опцию Use Project Frequency для задания установки 

глобальных частот поверх установки глобальных частот проекта. 

4. Убедитесь что установлены GHz в Data Entry Units. Вы можете задать 

глобальные частоты моделирования (выбором Options>Project Options и 

выбирая закладку Frequency Values) или локально используя эти шаги. Лучше 

использовать установки локальных частот для ЕМ структур, как вы обычно 

хотите для свипирования ЕМ структур для нескольких частотных точек 

которые моделируются с линейными схемами. 

5. Введите Start = (fгр− 0,5) и Stop= (frp + 0,5), и «0.1» в Step.  

6. Кликните Apply, окно Current Range показывает диапазон частот и 

шаги, которые вы настроили. Нажмите OK.  

 

2.8 Запуск моделирования 

ЕМ симулятор очень быстро решает небольшие задачи. Чтобы найти 

резонансную частоту фильтра, запустим моделирования для начальной 

топологии. 

1. Дважды нажмите Information под Interdigital Filter (под ЕМ Structure). 

Появляется диалог Solver Information для оценки времени моделирования 

данной структуры. 

2. Нажмите ОК для закрытия этого диалога. 

3. Выберите Simulate>Analyze. Индикатор процесса расчета показывает 

частоты, на которых выполняется решение пошагово и процесс решения 

электромагнитного симулятора (Рисунок 2.15). 

Совет: если величина требуемой памяти для решения данной задачи 

больше чем имеющаяся память, попробуйте переопределить задачу так, чтобы 

она запускалась с имеющейся памятью компьютера. 

2.9  Вывод результатов моделирования 

Для определения резонансной частоты вы можете вывести вносимые 

потери структуры. Чтобы показать характеристику на графике: 

1. Выберите Project>Add Graph. Появляется диалог Graph. 
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2. Выберите Rectangular как desired tуре и кликните Create. 

3. Кликните на окно Graph 1 для активизации его (Рисунок 2.16). 

4. Выберите Project>Add Measurement. Появляется диалог Add 

Measurement. 

5. Выберите S как характеристику, выберите Interdigital Filter как Data 

Source Name, выберите DB в разделе Complex Modifier, кликните Apply и 

затем ОК. 

6. Выберите Simulate>Analyze. Характеристика будет показана на 

графике. Характеристика показывает, что резонансная частота находится 

вблизи 4 ГГц. 

Для определения более точной характеристики резонансной частоты, вы 

можете изменить частотный диапазон и шаг частоты моделирования. 

 

Рисунок 2.15 – Процесс расчета 
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Рисунок 2.16 – Создание прямоугольного графика Graph 1 

2.10 Изменение диапазона частот и размера шага. 

1. В дереве проекта, нажмите правой кнопкой мыши на Interdigital 

Filter под ЕМ Structure и выберите Options. Появляется диалог Options. 

2. Выберите закладку Frequencies. 

3. Напечатайте значение Start и значение Stop, значение «0.1» как Step, и 

затем кликните Apply. Нажмите ОК.  

4. Выберите Simulate>Analyze для повторного моделирования 

структуры.  

5. Если график не полностью отображает нужный нам диапазон, 

измените значения Start и Stop в Options>Frequencies. 
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Рисунок 2.17 – Частотная характеристика 

2.11  Добавление резонаторов фильтра 

Для того чтобы получить окончательную  структуру фильтра, мы будем 

использовать несколько опций рисования. Чтобы добавить маленький 

проводник в конце входного резонатора: 

1. Кликните на окно Interdigital Filter чтобы сделать его активным. 

2. Поставьте курсор в верхний левый угол большего проводника и 

нажмите Ctrl+B(И). Это тоже, что и Draw>Rectangle 

3. Появляется диалог ввода координат. Просто нажмите ОК. 

4. Нажмите клавишу Tab снова и отметьте Re в диалоге ввода координат. 

5. Напечатайте «-0.4» как величину dx и «-0.2» как dy и затем нажмите 

ОК. Прямоугольный проводник покажется в окне ЕМ структуры (Рисунок 

2.18). Если маленький проводник находится не в том месте, как показано на 

рисунке, то передвиньте его. 
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Рисунок 2.18 – Установка порта и сдвиг референсной плоскости 

Чтобы нарисовать выходной резонатор: 

7. Выберите Edit>Select АН (выбрать все). 

8. Выберите Edit>Сору (копировать), и затем выберите Edit>Paste 

(вставить). 

9. Сдвиньте курсор и расположите копию вне входного резонатора. 

10. Если фигура не выделена полностью – выделите ее. Затем нажмите 

правую кнопку и выберете Flip. 

11. Кликните, а затем установите перевернутое изображение в место, 

противоположное входной линии (Рисунок 2.19). 

12. Выровняйте перевернутую часть фильтра с выходным краем. 

Для создания среднего резонатора: 

13. Кликните вблизи левого угла левого большого резонатора и охватите 

резонатор, путем перетаскивания курсора мыши, таким образом вы выделите 

большой резонатор и две перемычки. 

14. Выберите Edit>Сору а затем выберите Edit>Paste. Затем выделите 

две перемычки среднего резонатора, и перетащите их в нижнюю часть 

резонатора, как показано на рисунке 3.20. 
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Рисунок 2.19 – Процесс создания топологии фильтра 

  

Рисунок 2.20 – Окончательная топология фильтра 

2.12  Добавление выходного порта 

Для завершении ЕМ структуры, необходимо добавить порт на выход 

фильтра. Чтобы добавить порт и линию разгерметизации размером 1 мм: 

1. Кликните и активизируйте правую часть фильтра. 

2. Выберите Draw>Add Edge Port. 

3. Разместите курсор на правом краю фильтра и кликните на этом месте. 
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4. Внесите и передвиньте, аналогично первому порту, плоскость сдвига 

референсной плоскости, которую нужно протянуть до координаты dx: -1 . 

Окончательно структура имеет вид показанный на рисунке 3.20. 

5. Выберите Simulate>Analyze для анализа топологии. 

Добавьте на график также характеристику S21 в DB:  

6. Выберите Project>Add Measurement. Появляется диалог Add 

Measurement. 

7. Выберите S как характеристику, выберите Interdigital Filter как Data 

Source Name, выберите DB в разделе Complex Modifier, в To Port Index 

поставьте 2. Кликните Apply и затем ОК. 

8. Выберите Simulate>Analyze. График будет иметь вид, показанный на 

рисунке 3.21. 

 

Рисунок 2.21 –Частотная характеристика фильтра 

2.13  Изменение центральной частоты 

Посмотрите на рисунок  22. Если центральная частота вашего фильтра 

выше необходимой, то нужно ее уменьшить, для этого увеличьте ширину 

больших резонаторов на одно деление (0,2 мм). При этом расстояние между 

резонаторами тоже увеличьте. После этого проанализируйте схему снова. 

Если центральная частота вашего фильтра ниже необходимой, то 

уменьшите ширину больших резонаторов на одно деление (0,2 мм). При этом 

расстояние между резонаторами тоже уменьшите. После этого 

проанализируйте схему снова. 
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2.14 Полоса пропускания фильтра 

Теперь посмотрите на полосу пропускания фильтра. Если она меньше 

требуемой, то для увеличения полосы пропускания уменьшите расстояние 

между резонаторами. Если она больше требуемой, то для уменьшения полосы 

пропускания увеличьте расстояние между резонаторами. Увеличивая или 

уменьшая размеры, добейтесь необходимой полосы. 

В итоге получите фильтр с характеристиками, удовлетворяющими 

требованиям ТЗ по частоте и уровню затухания. Характеристики приведены на 

рисунке 3.22. в DB и на рисунке 3.23 в относительных еденицах. 

 

Рисунок 2.22 – Полоса пропускания и заграждения фильтра в DB 

 

Рисунок 2.23 – Полоса пропускания и заграждения фильтра в относительных 

единицах 
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3 Электродинамическое моделирование 

3.1  Анимирование тока и просмотр электромагнитного поля  

Просмотр анимированного тока и поля в структуре может быть полезной 

при исследовании его физических характеристик. Для анимирования тока на 

проводниках: 

1. Кликните окно 3D, чтобы сделать его активным. 

2. В дереве проекта, нажмите правой кнопкой мыши на Interdigital Filter 

под ЕМ Structure и выберете Add Annotation.  

3. В окне Measurement выберете EM_E_FIELD. Удостоверьтесь, что 

выбран второй слой. Нажмите OK. 

4. Выберете Simulate>Analyze.  

5. После этого на рисунке будут довольно яркие зеленые пометки, они 

показывают направление, чтобы их убрать нужно зайти в Properties нажав 

правой кнопкой на Interdigital Filter: EM_E_FIELD, и убрать Show Field 

Directions.  

6. В дереве проекта, нажмите правой кнопкой мыши на Interdigital Filter 

под ЕМ Structure и выберете Add Annotation еще раз. 

7. В окне Measurement выберете EM_CURRENT. Удостоверьтесь, что 

выбран первый слой. Нажмите OK. 

8. Выберете Simulate>Analyze.  
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Рисунок 3.1 – Визуализация и анимация вида тока на поверхности проводника 

 

 

Рисунок 3.2 – Просмотр напряженности поля в плоскости слоя 
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3.2  Поле и ток в полосе рабочих частот 

Полоса рабочих частот или ПП, посмотрите значения, соответственно 

своему варианту.  

Удалите слои EM_E_FIELD и EM_CURRENT 

1. Кликните правой кнопкой мыши на Interdigital Filter под EM Structures 

и выберете Options>Frequencies. 

2. Выставите значения соответствующие вашему варианту. Проследите за 

соответствием теоретического значения и практического. Нажмите Apply и 

OK. 

3. Выберите Simulate>Analyze. 

4. В дереве проекта, нажмите правой кнопкой мыши на Interdigital Filter 

под ЕМ Structure и выберете Add Annotation.  

5. В окне Measurement выберете EM_E_FIELD. Удостоверьтесь, что 

выбран второй слой. Уберите галочку в Show Field Directions, селектируйте dB, 

поставьте значение Log Range «100» Нажмите OK. 

6. Выберете Simulate>Analyze.  

7. Сделайте тоже самое, выбрав EM_CURRENT. 

Для сохранения Проекта на диске, из меню File (Файл) выберите Save 

(Сохранить) или Save As (Сохранить как). Далее задайте имя проекта и место 

сохранения. 

 


